myVertica  

9.1 Pre-Upgrade Script

Before you upgrade: Fix unsafe buddy projections

As of release 9.1, the SELECT and ORDER BY clauses of all projection buddies must specify columns in the same order. Before upgrading to version 9.1 or higher, current users are strongly urged to check that all projection buddies in the current database comply with these new requirements.


Warning: If the upgrade encounters non-compliant projections, it regards them as unsafe and the upgrade will fail. You must then revert to the previous installation.


Solution: Download and run the pre-upgrade script


The pre-upgrade script analyzes your current database and identifies unsafe projections. It then generates a DDL script that you can use before the upgrade to remedy these projections and ensure compliance with system K-safety.


README: Detailed information about the pre-upgrade script


Pre-upgrade script